Welcome Guest. ( logon | register )   
FAQ Member List Albums Today's Posts Search

PointedThree :  Vans, Trucks, SUVs and Other Forums : G-Class : Throttle response lag

Page 1 of 1 1
Throttle response lag
Topic Tools Message Format
Author
Posted 3/27/2019 11:06 AM
sdw96
Regular




Date registered: Mar 2012
Location: MA, USA
Vehicle(s): ‘15 G63, ‘19 BMW X7, 98 M3, 89 Grand Wagoneer
Posts: 68
50
Throttle response lag

This problem only pops up occasionally but when it does, it's exactly when you don't need it to.

For example, turning from a blind corner and needing to get into the throttle a bit more than usually when starting up from a stop, step on the gas and it seems to take a second to go. I'm sure the time is much less than that, but in the moment it's obviously noticeable. It only happens occasionally which makes me think it's not mechanical, but that is why I am asking for the group wisdom.

So intermittent slow throttle pickup. (2008 G500 110,000 miles). Is it an electronic issue somewhere or a mechanical issue and do I need to do something about it? Thanks All.
#240565
Top of the page Bottom of the page
Author
Posted 3/27/2019 2:53 PM
DUTCH
Administrator Doppelgänger




Date registered: Apr 2006
Location: US, GA, Atlanta
Vehicle(s): 2000 G500 NMLE,2015 Audi Q7 3.0 TDI,2018 Sprinter
Posts: 9817
5000
RE: Throttle response lag

Can you get a STAR scan to see if it shows anything? I'm wondering about the Throttle Position Sensor - i.e. "drive by wire" unit.
#240567 - in reply to #240565
Top of the page Bottom of the page
Author
Posted 3/29/2019 6:33 AM
Inkblotz
Expert




Date registered: Apr 2006
Location: Georgia
Vehicle(s): 90 300GD "Thundering Turtle II", w/ 603A turbo
Posts: 3083
2000
Re: Throttle response lag

I agree with Dutch. Take it to the dealer for a STAR hookup. There could be a software update as well. We have had this on our cars before.
#240574 - in reply to #240565
Top of the page Bottom of the page
Author
Posted 3/29/2019 9:15 AM
paulunm
Regular


Date registered: Jan 2015
Location: Los Angeles
Vehicle(s): 2000 G500
Posts: 87
50
Re: Throttle response lag

Could be worth cleaning the throttle body with some CRC Throttle Body Cleaner, common for them to get a bit gunked up on the m113.
#240577 - in reply to #240565
Top of the page Bottom of the page
Author
Posted 4/2/2019 11:11 PM
fernweh



Date registered: Apr 2006
Location: Calabasas, CA - Centenario, BCS - Luebeck, Germany
Vehicle(s): Few Mercedes-Benz, a Toyota Amphibious and a Vespa
2000
RE: Throttle response lag

You might want to adjust the foot pedal - cable - throttle position sensor.
Please look at the throttle position sensor location, and you will see an adjustment system for that cable.
The procedure is published in thew WIS......I don't have it not right now available to me.

With that adjustment I was able to correct the kick-down feature
#240586 - in reply to #240565
Top of the page Bottom of the page
Author
Posted 4/15/2019 4:16 AM
darko
Member


Date registered: Mar 2012
Location: Isle of Man
Vehicle(s): 2003 G500
Posts: 45
25
RE: Throttle response lag

I'm wondering if this is the same problem I am having ?

http://www.pointedthree.com/disc/forums/showthread.asp?tid=24043&po...
#240608 - in reply to #240565
Top of the page Bottom of the page
« View previous thread :: View next thread »
Page 1 of 1 1
Forum Jump :
All times are EST.  The time is now 2:27:11 AM.

Execution: 0.453 seconds, 94 cached, 11 executed.